Jump to content
datacoach

DBSAT Reporter Error.

Recommended Posts

Hi,

I tried to run the DBSAT for the first time and ran into an error at the "Running the Reporter", I have tried to search the Oracle Support Knowledge Center and also google for a solution but unfortunately can't get any answers.

See output below; Please advise.

[oracle@sample607 dbsat]$ ./dbsat report db04

Database Security Assessment Tool version 2.0.2 (May 2018)

This tool is intended to assist in you in securing your Oracle database system. You are solely responsible for your system and the effect and results of the execution of this tool (including, without limitation, any damage or data loss). Further, the output generated by this tool may include potentially sensitive system configuration data and information that could be used by a skilled attacker to penetrate your system. You are solely responsible for ensuring that the output of this tool, including any generated reports, is handled in accordance with your company's policies.

Archive:  db04.zip
[db04.zip] db04.json password:
  inflating: db04.json
Traceback (most recent call last):
  File "/home/oracle/dbsat/./sat_reporter.py", line 18, in <module>
    import sat_analysis as sat
  File "/home/oracle/dbsat/sat_analysis.py", line 13, in <module>
    import xlsxwriter
ImportError: No module named xlsxwriter
Error: Unexpected error occurred while running DBSAT Reporter.

Share this post


Link to post
Share on other sites

Hi,

I have no experience with dbsat, but the error looks like a pathing issue.

It’s having trouble finding the software.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×