Jump to content

JavierCZ

Members
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About JavierCZ

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. LSNRCTL> status Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC_FOR_XE))) STATUS of the LISTENER ------------------------ Alias LISTENER Version TNSLSNR for Linux: Version 11.2.0.2.0 - Production Start Date 28-MAY-2018 08:36:31 Uptime 0 days 0 hr. 45 min. 53 sec Trace Level off Security ON: Local OS Authentication SNMP OFF Default Service XE Listener Parameter File /u01/app/oracle/product/11.2.0/xe/network/admin/listener.ora Listener Log File /u01/app/oracle/diag/tnslsnr/gica2/listener/alert/log.xml Listening Endpoints Summary... (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC_FOR_XE))) (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=[domain])(PORT=1521))) (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=[domain])(PORT=8080))(Presentation=HTTP)(Session=RAW)) Services Summary... Service "PLSExtProc" has 1 instance(s). Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service... Service "XE" has 1 instance(s). Instance "XE", status READY, has 1 handler(s) for this service... Service "XEXDB" has 1 instance(s). Instance "XE", status READY, has 1 handler(s) for this service... The command completed successfully
  2. I have two Intranet servers and one in the cloud that connects me through VPN. My intention is to be enabled for REDUCTION and for that I need to do a Shutdown and a Starup. but in doing so he returns me: ORA-12514: TNS:listener does not currently know of service requested in connect descriptor On the intranet versuon I did not have problems to restart the ORACLE from the sqlplus but in the cloud have this problem. I do not have a sqlnet.ora file and I use the version of Oracle 11 g2 XE. - My tnsnames.ora is: XE = (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = [dominio] )(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = XE) ) ) EXTPROC_CONNECTION_DATA = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC_FOR_XE)) ) (CONNECT_DATA = (SID = PLSExtProc) (PRESENTATION = RO) ) ) - And my listener.ora is: SID_LIST_LISTENER = (SID_LIST = (SID_DESC = (SID_NAME = PLSExtProc) (ORACLE_HOME = /u01/app/oracle/product/11.2.0/xe) (PROGRAM = extproc) ) ) LISTENER = (DESCRIPTION_LIST = (DESCRIPTION = (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC_FOR_XE)) (ADDRESS = (PROTOCOL = TCP)(HOST = [dominio] )(PORT = 1521)) ) ) DEFAULT_SERVICE_LISTENER = (XE) In the intranet version only changes the HOST from [domain] to 'intranet'. 'intranet' returns 172.160.0.1, but in the cloud it returns an external IP. I have tried to modify the host to localhost or an internal ip but the result is the same. When I connect I create the following variables from the PUTTY, which are the same as in the intranet (and the structure is the same as it is a replica) export ORACLE_BASE=/u01/app/oracle export ORACLE_HOME=/u01/app/oracle/product/11.2.0/xe export ORACLE_SID=XE export ORACLE_TERM=xterm export ORACLE_OWNER=oracle export PATH=$ORACLE_HOME/bin:$PATH export LD_LIBRARY_PATH=$ORACLE_HOME/lib export NLS_LANG=SPANISH_SPAIN.AL32UTF8 export NLS_DATE_FORMAT='DD/MM/YYYY HH24:MI:SS' export NLS_TIMESTAMP_FORMAT='DD/MM/YYYY HH24:MI:SS' export NLS_NUMERIC_CHARACTERS='.,' I have tried everything and more with what I have trouble restarting the DB when it is working and having to eject the users connected. Every time I try to turn the database on and off from the SQLPLUS it returns this error and I have to go to the Service to stop it and raise it. Fact that makes it unable to activate the Archivelog. Someone knows what it can be, I would appreciate it if you would help me. Greetings and thanks
×